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Tub e  Conn e c t i o n

A tube connection consisting of a flange with four prestressed bolts is subjected to 

tensile forces. A sketch of the connection is shown below.

Model Definition

The tube is made of steel and has an outer diameter of 220 millimeters and an inner 

diameter of 200 millimeters. The flange has a diameter of 360 millimeters and it is 

30 millimeters thick. The connection consists of four prestressed M24 bolts. The bolts 

are prestressed to 80% of the yield strength. The tensile force in the tube varies from 0

to 500 kN.

To compute the influence of the tensile force on the stress level in the bolt, the model 

includes a parametric analysis. Because of symmetry in both load and geometry, you 

only need to analyze one eighth of one of the flanges. The geometry has been created 

in the CAD software SolidWorks and is available both as an IGES file and as a 

SolidWorks file. The model exists in two different versions depending how the 

geometry is imported. The IGES version (tube_connection_igs.mph) is created 

from the IGES file through the IGES file import. Read more about IGES import in 

the section Importing 3D IGES Files in the CAD Import Module User’s guide. The 

SolidWorks version (tube_connection_sw.mph) is created from the SolidWorks live 

connection. Read more about the SolidWorks interface in the section “SolidWorks 

Live Connection” on page 30 in the CAD Import Module User’s guide.
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A contact pair between the bottom surface of the flange and the top surface of an 

additional fixed solid models the contact. To represent the bolt, the model uses a 

distributed linear boundary condition on a surface of the size of the washer.

Note: This model requires both the Structural Mechanics Module and the CAD 

Import Module.

Modeling in COMSOL Multiphysics

Two application modes for 3D solid stress-strain analysis are used to solve the problem. 

One application mode models the initial prestress problem of calculating the 

deformation from the prestressed bolts. The other is used for solving the parametric 

problem including the tensile force, using the solution from the prestress application 

mode to set up the correct boundary conditions.

Results and Discussion

Figure 7-8: The bolt stress as a function of the tensile force.
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For a tensile force below 250 kN the prestressed connection works well, the bolt stress 

increasing less than 2%. In the region 250 kN–500 kN the bolt stress increases by more 

than 13% due to the nonlinear effects in the connection.

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/ 

tube_connection_igs

Model Library path: Structural_Mechanics_Module/Contact_and_Friction/

tube_connection_sw

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 Click the New button or start COMSOL Multiphysics to open the Model Navigator.

2 Select 3D in the Space dimension list.

3 In the list of application modes, open the Structural Mechanics Module folder and 

then Solid, Stress-Strain. Select the Static analysis.

4 Click OK.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, select Constants.

2 Enter the following constant names, expressions, and (optionally) descriptions. 

When finished, click OK.

NAME EXPRESSION DESCRIPTION

Abolt pi/4*24e-3^2[m^2] Bolt area

Atube pi/4*(0.22^2-0.2^2)[m^2] Tube area

Force 0[N] Tensile force in the tube

Sboltini 800*0.8*0.8*1e6[N/m^2] Prestress in the bolt

Awash pi/4*(0.05^2-0.025^2)[m^2] Washer area

thickness 0.03[m] Flange thickness
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G E O M E T R Y  M O D E L I N G

There are two different ways to create the geometry:

• From an IGES file, through the IGES file import.

• From a SolidWorks file, through the SolidWorks live connection.

IGES File Import

1 On the File menu, select Import>CAD Data From File to open the Import CAD Data 

From File dialog box.

2 Open the IGES file tube_connection.igs located in the 

models\Structural_Mechanics_Module\Contact_and_Friction folder in the 

COMSOL installation directory.

3 Click Import.

Emod 2e11[N/m^2] Modulus of elasticity of the 

bolt

Kbolt Emod*Abolt/thickness/Awash Distributed stiffness of the 

bolt (N/m3)

Fbolt Sboltini*Abolt/Awash Distributed prestress from 

the bolt (N/m2)

NAME EXPRESSION DESCRIPTION
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Due to symmetry, you can reduce the geometry to one eighth of the full geometry. To 

do so, create a 45-degree wedge and then intersect it with the imported geometry:

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box as you will use the default settings.

3 Click the Zoom Extents toolbar button.

4 Draw a rectangle with opposite corners at (0, −0.1) and (0.2, 0.2).

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 

Click OK.

6 Press Ctrl+A to select all objects and then click the Intersection button on the Draw 

toolbar to create an eighth.

Model a washer by creating a boundary around the hole. The distributed forces from 

the bolt are applied on this boundary.

1 Select Work-Plane Settings from the Draw menu.

2 Click the Add button, select the z-x option in the Plane area and click OK.

3 Set grid settings in Geom 3 according to the following table:

4 Click the Zoom Extents button on the Main toolbar to see the geometry.

5 Press the Shift key and click the Ellipse/Circle (Centered) button on the Draw toolbar 

to create a centered circle with radius 0.025 and center at (0, 0.15).

6 Draw another centered circle with radius 0.0125 and center at (0, 0.15).

7 Select both circles and click the Difference button to create a washer.

8 Draw a rectangle with opposite corners at (0, 0.12) and (0.03, 0.18).

9 Click the Create Composite Object button on the Draw toolbar, type CO1-R1 in the 

Set formula edit field, and click OK to close the dialog box.

GRID
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y spacing 5e-3

Extra y
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10 Select Embed from the Draw menu, then click OK.

Create an additional solid below the bottom flange (this solid is needed for the contact 

modeling).

1 Select Work-Plane Settings from the Draw menu.

2 Click the Add button, select the x-y option in the Plane area and click OK.

3 Set grid settings in Geom4 according to the following table:

4 Draw a rectangle with opposite corners at (0.09, −0.04) and (0.19, −0.03). To do 

so, press Shift and click the Rectangle/Square button on the Draw toolbar. In the 

Rectangle dialog box, enter (0.09, −0.04) as the coordinates for lower-left corner 

and a width and height of 0.10 and 0.01, respectively.

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 

Click OK.

GRID
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You need to work in assembly mode to model the contact between the two initially 

connecting solids. The embedded washer surface must be a part of a solid to be 

included in the assembly between solids.

1 Select the upper solid part, CO2, and the embedded surface, EMB1.

2 Click the Coerce to Solid button on the Draw toolbar to make the washer a part of 

the solid.

3 Select Use Assembly from the Draw menu to leave draw mode in assembly mode.

SolidWorks Live Connection

Another way to create your geometry is to import it directly from SolidWorks. To 

follow these instructions you need to have SolidWorks installed on your computer.

1 Start SolidWorks and open the SolidWorks file tube_connection.SLDPRT located 

in the models/Structural_Mechanics_Module/Contact_and_Friction in the 

COMSOL installation directory.

2 Switch to COMSOL and select File>SolidWorks Connection>Initialize.

Create an additional solid below the bottom flange, this solid is needed for the contact 

modeling.

1 Select Work-Plane Settings from the Draw menu.

2 Click OK in the Work-Plane Settings dialog box as you will use the default settings.

3 Set grid settings in Geom2 according to the following table:

4 Draw a rectangle with opposite corners at (0.09, −0.04) and (0.19, −0.03).

5 Select Revolve from the Draw menu and enter 45 as α2 in the Revolve dialog box. 

Click OK.

You need to work in assembly mode to model the contact between the two initially 

connecting solids.

6 Select Use Assembly from the Draw menu to leave draw mode in assembly mode.
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P H Y S I C S  S E T T I N G S

Boundary Settings

In the first application mode you compute the initial deformation from the prestressed 

bolt. You then use a second Solid Stress-Strain application mode for the parametric 

analysis where the tensile force in the tube is increased. You need the solution from the 

first application mode to set up the boundary conditions for the parametric analysis.

1 Select Model Navigator from the Multiphysics menu to open the Model Navigator.

2 Select Structural Mechanics Module>Solid, Stress-Strain from the application mode 

tree and click the Add button to add a second solid stress-strain application mode to 

your 3D geometry. Click OK to close the Model Navigator.

To model the contact, use contact pairs. Start by creating two contact pairs, one for 

each application mode. Make the weaker boundary the slave and the stiffer one the 

master boundary.

3 Select Physics>Contact Pairs to open the Contact Pairs dialog box.

4 Click the New button to create a contact pair.

5 Select Boundary 4 in the Master boundaries list.

6 Select the check box in front of 4 in the Master boundaries list.

7 Select Boundary 9 in the Slave boundaries list.

8 Select the check box in front of 9 in the Slave boundaries list.

9 Click the New button to create an additional contact pair.

10 Select the same boundaries as master and slave boundaries as you made for the first 

pair.

11 Click OK to close the dialog box.

12 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.

13 Select Physics>Boundary Settings and clear the Active pair check box for Pair 2.

14 Select 2Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu.

15 Select Physics>Boundary Settings and clear the Active pair check box for Pair 1.

16 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu.
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17 Select Physics>Boundary Settings and specify the boundary and contact-pair settings 

according to the following tables:

The auglagiter variable is the iteration number in the augmented Lagrange solver. 

It makes the penalty parameter soft at the beginning (to help the solver get started) 

and then gradually makes it stiffer (to speed up convergence).

18 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu.

19 Select Physics>Boundary Settings and specify the boundary and contact pair settings 

according to the following tables:

20 For enabling plotting of the bolt stress as a function of the applied tensile force an 

integration coupling variable is created, representing the integral of the force on the 

washer boundary.

21 Select Options>Integration Coupling Variables>Boundary Variables to open the 

Boundary Integration Variables dialog box.

22 Select Boundary 15 in the Boundary selection list.

23 In the Name column type Boltstress.

24 In the Expression column type (Fbolt+Kbolt*(v2-v))/(Abolt/2).

BOUNDARIES 8, 14, 18 BOUNDARY 15

Page Constraint Load

Symmetry plane Fy -Fbolt

PAIR 1 PAIR 2

Page Contact

pn E_smsld/h*min(1e-3*5^auglagiter,100)

Page Contact, Initial

Tn 1e7

BOUNDARIES 8, 14, 18 BOUNDARY 10 BOUNDARY 15

Page Constraint Load Load

Symmetry plane Fy Force/Atube Fy -Fbolt-Kbolt*(v2-v)

PAIR 2 PAIR 1

Page Contact

pn E_smsld2/h*min(1e-3*5^auglagiter,100)

Page Contact, Initial

Tn Tn_cp1_smsld
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25 Leave Global destination enabled and click OK to close the dialog box.

Subdomain Settings

The material properties will be defined using the materials library and are identical for 

both application modes. Specify the extra solid (added for the contact modeling) to be 

fixed.

1 Select 1 Geom1: Solid, Stress-Strain (smsld) from the Multiphysics menu to set the 

subdomain parameters for the first application mode.

2 Select Physics>Subdomain Settings.

3 Select Subdomain 2 from the subdomain list. Click the Load button on the Material 

page to open the Materials/Coefficients Library dialog box.

4 Select Structural Steel from the Basic Material Properties folder and click OK to close 

the Materials/Coefficients Library dialog box. 

5 Select Subdomain 1 from the subdomain list. Click the Constraint page and select 

Fixed from the Constraint condition list.

6 Click OK to close the Subdomain Settings dialog box.

Do the same for the other application mode:

7 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the Multiphysics menu to set the 

subdomain parameters for the second application mode.

8 Select Physics>Subdomain Settings.

9 Select Subdomain 2 from the subdomain list.

10 Select Structural Steel from the Library material list.

11 Select Subdomain 1 from the subdomain list. Click the Constraint page and select 

Fixed from the Constraint condition list.

12 Click OK to close the Subdomain Settings dialog box.

M E S H  G E N E R A T I O N

The default mesh settings are used.

C O M P U T I N G  T H E  S O L U T I O N

1 Select Solver Parameters from the Solve menu.

2 Click the Stationary tab and find the Augmented Lagrangian solver area.

3 In the Tolerance edit field type 1e-5.

4 Click OK to close the Solver Parameters dialog box
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First solve the initial problem (no tensile force, only prestress) to determine the initial 

displacements.

1 Select Solver Manager from the Solve menu to open the Solver Manager dialog box.

2 On the Solve For page select Geom1: Solid, Stress-Strain (smsld) from the Solve for 

variables list, then click OK to close the dialog box.

3 Click the Solve button on the Main toolbar to compute the solution.

You have now solved the prestress problem without any external load.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

Visualize the displacement in the y direction and the deformation as follows:

1 Select Plot Parameters from the Postprocessing menu.

2 On the General page select Frame (ref) from the Frame list.

3 Clear Slice plot, then select Deformed shape plot and Subdomain plot.

4 Click the Subdomain tab.

5 From the Predefined quantities list select Solid, Stress-Strain (smsld)>y displacement.

6 Click OK.

Now consider the externally applied tensile force.
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C O M P U T I N G  T H E  S O L U T I O N

Switch to the parametric solver and solve for the displacements in the second 

application mode using the solution from the first application mode in the boundary 

condition and as initial condition.

1 Select Solver Parameters from the Solve menu to open the Solver Parameters dialog 

box.

2 Select Parametric in the Analysis list.

3 On the General page type Force in the Parameter name edit field and type 

0:50e3:500e3 in the Parameter values edit field. Click OK.

4 Choose Solve>Solver Manager, then click the Initial Value tab.

5 Click the Initial value expression evaluated using stored solution option button in the 

Initial value area.

6 Click the Stored solution option button in the Values of variables not solved for and 

linearization point area.

7 Click the Store Solution button to save the initial solution.

8 Select Geom1: Solid, Stress-Strain (smsld2) from the Solve for variables list on the Solve 

For page, then click OK to close the dialog box.

Set the initial values in the second application mode to the result from the first 

application mode.

1 Select 2 Geom1: Solid, Stress-Strain (smsld2) from the multiphysics menu.

2 From the Physics menu, choose Subdomain Settings.

3 Click the Init tab and specify the initial values according to the following table.

4 Click OK.

5 Click the Solve button on the Main toolbar to start the parametric solver.

P O S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To visualize the result of the parametric analysis, you can use a plot of the von Mises 

stress combined with a deformation plot:

SUBDOMAIN 1, 2

Page Init

u2(t0) u

v2(t0) v

w2(t0) w
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1 From the Postprocessing menu, select Plot Parameters.

2 Select 5e5 in the Parameter value list on the General page.

3 Click the Deform tab.

4 In the Deformation data area, select Solid, Stress-Strain (smsld2)>Displacement in the 

Predefined quantities list.

5 Click the Subdomain tab.

6 Select Solid, Stress-Strain (smsld2)>von Mises stress from the Predefined quantities list.

7 Click OK.

To plot the stress in the bolt as a function of the external tensile force, do the following 

steps:

1 From the Postprocessing menu, choose Global Variables Plot Parameters.

2 Make sure that all parameter values are selected in the Solutions to use list.

3 Enter Boltstress in the Expression edit field and click the > button.

4 Select Boltstress from the Quantities to plot list.
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5 Click OK to create the plot.


