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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialIntroduction [1]
• Several solution strategies exist when there are moving parts in the 

domain.  This workshop will show two such strategies on the same model.

• The application is a vertical axis wind-The application is a vertical axis wind
turbine.  This CFD model is a horizontal 
plane cut through the 4 vertical blades.

• To help understand the motion, look in the 
project folder and play the included movie 
file ‘ws5-mesh-animation.avi’
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialIntroduction [2]

• Part 1:  This motion will be simulated using 
the steady-state solver, defining the motion 
using Moving Reference Frames (MRF)g g ( )

• Part 2:  The same problem will be solved in p
a transient manner, moving the mesh using 
Sliding Meshes

BladeBlade 
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Customer Training Material

Part 1 :   Using Moving Reference Frames
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialStarting FLUENT in Workbench
1. Open the Workbench

Start > Programs > ANSYS 13.0 > ANSYS Workbench

2. Drag FLUENT (‘Component Systems’)  into the project schematic
3. Change the name to Moving Reference Frame
4. Double click on Setup
5 Choose 2D and5. Choose 2D and

“Double Precision” under 
Options and retain the other 
d f lt ttidefault settings
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialImport Mesh
• This starts a new FLUENT session and the first step is to import the 

mesh that has already been created:
1. Under the File menu select Import Mesh
2. Select the file ws5-simple-wind-turbine.msh and click OK to import the mesh 

and check the scaling by using Scale under Problem Setup General.  
The blades are 1m radius from the origin (0,0), with the outer bounding box +/- 5m in all directions. 

3 After reading the mesh check the grid using Mesh > Check option3. After reading the mesh, check the grid using Mesh > Check option
or by using Check under Problem Setup > General

The mesh check will fail!
To allow for the motion later in this workshop, there are 
intentional non-conformal interfaces (where the mesh 
nodes do not match across an interface).   These need 
to be paired up in the solver so that interpolation acrossto be paired up in the solver so that interpolation across 
the interface can occur – so fluid can flow across this 
join.
More generally, if in DesignModeler you produce several 
different parts, the mesh will also be non-conformal, and 

ill d t f th t t t k th
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you will need to perform the next step to make sure the 
solver interpolates across the interface.



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialMesh Interfaces
• Under Problem Setup > Mesh Interfaces
– Click Create/Edit
– For each row in the table below:

1. Enter the name of the mesh interface (column 1)
2. Click on the name of Interface Zone 1 (column 2)
3. Click on the name of Interface Zone 2 (column 3)
4 Cli k C t

Note how the nodes do not 
match across the interface.  
• The boundary on the 

4. Click Create
– Repeat the mesh check.  It should now pass

black side is  ‘Int-hub-a’  
and the red side is ‘Int-
hub-b’ 

Mesh 
Interface

Interface Zone 
1

Interface Zone 
2

in_hub int-hub-a int-hub-b

1
2 3

in_xneg int-xneg-a int-xneg-b

in_xpos int-xpos-a int-xpos-b

in yneg int-yneg-a int-yneg-b
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSetting up the Models
• Keep the Pressure Based, Steady State solver
– Problem Setup > General > Solver

• Specify Turbulence modelp y
– Problem Setup > Models > Viscous
– Double click and select k-epsilon (2 eqn) under Model and Realizable under 

k-epsilon model and retain the default settings for the other parameters
• For Materials, keep the default 

properties of the material air
density: 1.225 kg/m³ 
viscosity: 1.7894e-5 kg/(ms) 
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialCell Zone Conditions (1)
• Under Problem Setup > Cell Zone Conditions
– Select fluid-outer-domain and click Edit
– Observe air is already selected and click OK

This zone is a stationary 
zone. It is not necessary to 
define a motion.

fluid-outer-domain

fluid-blade-ypos

fluid-rotating-core

fluid-blade-xneg

fluid-blade-xpos

fluid-blade-yneg
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialCell Zone Conditions (2)
• Select fluid-rotating-core and click Edit
– Observe air is already selected
– Click Frame Motion, to activate the Moving Reference Frame model
– Retain the (0 0) as Rotational-Axis Origin
– Select 4 rad/s as Rotational Velocity and click OK

We can account for the motion of 
the parts, even in a steady state 
solver by using this technique. 
By specifying the rotation of the 
core, all the grid cells are given 
an additional source term to 
account for the local 
acceleration This is known asacceleration.  This is known as 
using a moving reference frame.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialCell Zone Conditions (3)
• Select fluid-blade-xneg and click Edit
– Observe air is already selected
– Click Frame Motion, to activate the Moving Reference Frame model
– Set the Rotational-Axis Origin to [-1 0]
– Set the Rotational Velocity to 2 rad/s
– Select fluid-rotating-core as Relative Specification and click OK

This zone is rotating about its 
own axis, which is 1m away 
from the global (hub) axis.  
The rotation speed is half 
that of the outer hubthat of the outer hub.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialCell Zone Conditions (4)
• Repeat the instructions on the previous Slide for the other 3 blades:

– Zone fluid-blade-xpos Axis  [1  0]     Speed 2rad/s    Relative fluid-rotating-core
– Zone fluid-blade-yneg Axis  [0 -1]     Speed 2rad/s    Relative fluid-rotating-core
– Zone fluid-blade-ypos Axis  [0  1]     Speed 2rad/s    Relative fluid-rotating-core

Axis is different for 
each zone
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialBoundary Conditions (1)
• Under Problem Setup > Boundary Conditions
– Vel-Inlet-Wind

• Select vel-inlet-wind, click Edit and set 10 m/s as Velocity Magnitude
• Choose Intensity and Length Scale under Turbulence
• Set Turbulence Intensity to 5 % and Turbulent Length Scale to 1 m and click OK

– Pressure-Outlet-Wind
S l t tl t i d li k Edit d t 0 P G P• Select pressure-outlet-wind, click Edit and set 0 Pa as Gauge Pressure

• Choose Intensity and Length Scale under Turbulence
• Set Turbulence Intensity to 5 % and Turbulent Length Scale to 1 m and click OK
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialBoundary Conditions (2)
• Under Problem Setup > Boundary Conditions
– Rotating wall

• Double-click wall-blade-xneg and select Moving Wall under Wall Motion
• Select Rotational under Motion and retain 0 rad/s as Speed relative to cell zone

The solver needs to know the speed of 
the wall so as to properly account for wall 
shear.  Since the motion has been set in 
the cell zone we will simply tell thethe cell zone, we will simply tell the 
boundary condition to use the same 
conditions (that is, zero velocity with 
respect to the cell zone).

Note that this panel will tell you which cell 
zone is adjacent to this wall – look at the 
greyed-out box on the second line.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialBoundary Conditions (3)
• Copy the boundary conditions to other zones

1. Select Copy

To save time, when 
b d i h id ti lboundaries have identical 
parameters, we can copy 
from one to (many) 
others.

2. Select wall-blade-xneg
3. Select the three other blades3. Select the three other blades 

zone (wall-blade-xpos, wall-
blade-yneg, wall-blade-ypos)

4. Click Copy, then OK
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4. Click Copy, then OK
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Customer Training MaterialSolution Methods
• Under Solution > Solution Methods
– Select “Second Order Upwind“ for 

Momentum, and the turbulence equations

• Under Solution > Solution Controls
– Retain the default settings
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialInitialization
• Under Solution > Solution Initialization
– Select Standard Initialization
– Choose vel-inlet-wind under Compute from
– Select Absolute under Reference Frame and 

click Initialize
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialWrite Case and Data File
• The model is now ready to run.

• First Save the Project to your normal working directoryFirst Save the Project to your normal working directory
– File > Save Project      

• Then Run the CalculationThen Run the Calculation
– Set 500 as Number of Iterations
– Click Calculate to start the steady state simulation

It will reach the default convergence criteria in just over 200 iterations– It will reach the default convergence criteria in just over 200 iterations

Generally you should always 
do further checks to determine 

H tconvergence.  However to 
save time in this example we 
will simply assume the default 
convergence criteria are 
sufficient.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialPost Processing
• You can post process the results in FLUENT
– Results > Graphics and Animations 
– Select Contours and click Set Up
– Select Velocity under Contours of and Velocity Magnitude below that
– Tick the box “Filled“, but do not select any surfaces, then Display
– Zoom in on the hub using the middle mouse button, by drawing a box from top-

left to bottom-right

It is not necessary toIt is not necessary to 
select a plotting surface 
when using FLUENT in 
2D.  By default the plot 
value is shown on all 

• Drag zoom box with middle mouse button.
• Opposite direction (right to left) will zoom out
• Use ‘Fit To Window’ to reset if necessary
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialPost Processing [2]
• The Velocity contours should look like this:

Without the cell zone 
motion (MRF) this would 
have looked much more 
symmetrical between top 
and bottom

4 rad/s Hub 
Rotation10 m/s 

wind

You can save this image 
from FLUENT for use in a 
report:
• File > Save Picture
• TIFF and Colour• TIFF, and Colour
• Resolution 1200 x 1200
• ‘Save’
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialWrite Case and Data File
• Save the project
– File > Save Project

• Close FLUENT and return to the ANSYS Workbench window• Close FLUENT, and return to the ANSYS Workbench window.
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Customer Training Material

Part 2 :   Using Sliding Meshes

WS5-22
ANSYS, Inc. Proprietary
© 2010 ANSYS, Inc.  All rights reserved.

Release 13.0
December 2010



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSliding Meshes - Introduction
• There are times when the MRF assumption used in Part 1 is an over-

simplification of the problem.
– Only one position of the hub relative to the incoming wind was simulated
– There will also be some vortices that affect each blade from other blades that 

have just passed upwind.

• In this next part, we will actually move the relative positions of all the 
components within FLUENT, and solve this in a transient (time-dependant) 
manner.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialPreparing Workbench
• On the Workbench Project Page, 

right-click on the arrow at the top of 
the FLUENT model, and select 
‘Duplicate’Duplicate

• Name the newly created copy ‘Sliding 
Mesh Model’Mesh Model

• Drag the results over from the MRF 
model (drag a line from cell A3 to B3) ( g )

• This is so we can use the steady-
state solution as a starting point 
for the new Sliding Mesh 

t ticomputation.

• Launch FLUENT by double clicking on 
the new Solution cell (B3)
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the new Solution cell (B3)



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialModel Setup – General Comments
• All the model setup values (boundary conditions, etc) are available in the 

new FLUENT session.

• You may want to have a look (boundary conditions, plot velocity contours 
etc) to observe this for yourself.

• The following slides will show how to change this model to a sliding mesh 
case.

• Note that whereas the motion of the hub is easy to define (rotates about a 
fixed axis), it is harder to define the motion of the blades because their axis 
moves in addition to the rotation of the blademoves, in addition to the rotation of the blade.

• Supplied with this case is a FLUENT User Defined Function (UDF) to 
apply the rotation and translation to each blade
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apply the rotation and translation to each blade.



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSolver Setup
• Select Transient solver

– Problem Setup > General > Solver

• Read in the supplied UDF 
– Copy the UDF ws5_udf_for_motion.c to the 

‘user_files’ subdirectory of your project 
– Define User Defined Functions Interpreted
– Select Browse, and pick this .c file from user_files
– Enable ‘Display Assembly Listing’ 

and ‘Contributed CPP’
– Watch the FLUENT TUI window as you select ‘Interpret’
– If successful, you will see no errors in the TUI window, 

just about 700 lines of machine code scroll past.

UDFs will be covered in more detail in their own lecture.  There are two 
basic approaches Interpreted or Compiled We have opted for Interpreted
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basic approaches, Interpreted or Compiled.  We have opted for Interpreted 
here because this is a simple and quick to execute UDF (so run speed is not 
an issue), and because no additional software is needed on your computer.  



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSetting up Cell Zones [1]
• Under Problem Setup > Cell Zone Conditions
• Select fluid-rotating-core and click Edit
– Click Copy to Mesh Motion in the py

Reference Frame Tab to activate the
Sliding Mesh model

– The motion type is changed from ‘Frame Motion’
to ‘Mesh Motion’

– Move to the Mesh Motion Tab and observe the 
rotation speed has been transferred

– click OK
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSetting up Cell Zones [2]
• The setup will be slightly different for the 4 blades.
• Select fluid-blade-xneg and click Edit
– The motion will be set maually via the UDF, we do not need to copy values y , py

from the MRF settings  (The UDF has hard-coded the axis position and speed)
– Un-select ‘Frame Motion’
– Select ‘Mesh Motion’
– On the Mesh Motion Tab,  for UDF

select ‘motion_xneg’
be careful to pick the correct UDF 
and only select ‘Mesh Motion’!

– Select ‘OK’
• Repeat the above for the other zones:
– fluid-blade-xpos (motion_xpos)
– fluid-blade-yneg (motion_yneg)
– fluid-blade-ypos (motion_ypos)
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be careful to pick the correct corresponding UDF. Re-visit each cell zone and 
verify the settings are correct



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSetting up an Animation
• Solution > Calculation Activities > Solution Animations > Create/Edit
– In the Solution Animation Panel increase the Animation Sequences to 1
– Select Time Step under When and click Define
– In Animation Sequence Panel select Window 2, SET, then Contours

It is very useful with transient simulations to record key frames of theIt is very useful with transient simulations to record key-frames of the 
solution progress.  Not only does this help understand the result, but 
also aids de-bugging if the settings are not as intended.
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialSetting up an Animation [2]
• On the Contour Panel:
– Set  Contours of Velocity > Velocity Magnitude
– Select ‘Filled’

Forcing a Max and Min 
value will ensure all 
frames in the animation 
are consistent

– Deselect Global Range, Auto Range and Clip to Range
– Enter Min=0, Max=20
– Deselect all surfaces

are consistent.

– Click ‘Display’
– Close the Contour Panel
– OK the Animation Sequence Panel
– OK the Solution Animation Panel

• Graphic layout:Graphic layout:
– Enable 2-window display
– Use the middle mouse button

to zoom in on the blades in
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to zoom in on the blades in
graphic window 2 



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialWrite Case and Data File
• The model is now ready to run.

• First Save the Project to your normal working directoryFirst Save the Project to your normal working directory
– File > Save Project      

• Then Run the CalculationThen Run the Calculation
– Set 0.005s as time step size
– Set 314 as number of time steps 
– 4 rads/sec equates to 1.57secs/rotation.   0.005s x 314 = 1.57sads/sec equates to 5 secs/ otat o 0 005s 3 5 s

– Click Calculate to start the transient simulation

An Initialization of this case is 
not necessary because we 
want to continue the simulation 
with “start condition” of the
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with start condition  of the 
Moving Reference Frame



WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialReviewing the Solution
When the calculation is complete:
• Graphics and Animations > Solution Animation Playback > Setup
– Selecting the ‘Play’ button will let you review the animationg y y

– Alternatively you can select Write/Record Format, and type MPEG.
(this will appear in the folder   ( pp
working directory\workbench_project_name\dp0\FLU-1\Fluent)
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialComparing the Results
• The images below show a comparison of the result from the MRF and 

sliding mesh approaches.
• Although the MRF approach gave a useful early indication of the velocity 

field and wake behind the blades, a full Transient approach was needed.

MRF Result (Part 1) Sliding Mesh Result (Part 2)
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WS5: Using Moving Reference Frames and Sliding Meshes

Customer Training MaterialClosing Comments
• Save the Project
– File > Save Project

• This workshop has shown how the fluid region can be modified by the 
solver at every timestep.  There is no need to have to go back to the pre-y p g p
processor to generate a fresh mesh at each step.

• The key feature needed in the mesh in order to do this was havingThe key feature needed in the mesh in order to do this was having 
different, disconnected (non-conformal) cell zones.  Since they are 
disconnected, FLUENT could move them as a rigid body

• If the parts actually change shape, there are further tools available in 
FLUENT (the Dynamic Mesh Model) which allow much greater changes to 
be made to the mesh adding and removing grid cells where necessary
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be made to the mesh, adding and removing grid cells where necessary.
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Customer Training MaterialOptional Extras
• If you have finished early, ahead of the rest of the class, you may want to 

investigate reporting the turning moment on the device.

– Use Report Forces Moments (and set appropriate axes)
– Pick the 4 blades
– Compare the result from the two cases computed.

– The Moment Coefficient can also be plotted as a graph during the solution 
process  Monitors Moment.

– Click the ‘Help’ button on this panel and follow the link to ‘Monitoring Force and 
Moment Coefficients’ to find out more.

– Note that this reports a coefficient, which uses the values set in 
R t R f V l ( h l )Report Reference Values (see help pages).

– Once set, if you run the solver on for further timesteps, you will see how the 
moment varies sinusoidally as the device rotates.
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