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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialIntroduction and Problem Description 

• Process Gas and Liquid Droplets come into a Reactor

We will use the Discrete Phase Model (DPM) to track the Liquid• We will use the Discrete Phase Model (DPM) to track the Liquid 
Droplets

F h i i i h l ll d l i h• For the process, it is important that only small droplets come into the 
Reaction Zone, to avoid blockage in the catalyst

• If droplets hit the Reactor Wall, they run down – So, it is not 
necessary to treat them as droplets after hitting the wall
– Larger droplets will be removed with this logic and only smaller droplets 

will stay in the domain and pass through to the outlet which is the inlet to 
the reaction zone.
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• The problem is treated as isothermal.
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialStart-up and Mesh Modification
• Launch FLUENT running Double Precision

We will convert the Tetrahedral elements to 
Polyhedral elements to reduce the total cell 
count (so the simulation will proceed more 
quickly).  Since polyhedral cells are less 
diffusive than the original tetrahedral cellsdiffusive than the original tetrahedral cells, 
this should not reduce the overall accuracy.

Take the option (see Image):• Take the option (see Image):
– Mesh > Polyhedra > Convert Domain

The cell count is reduced to 45,000 from the 
previous 101,000
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• Re-display the mesh to see the effect



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Single Phase (1)

• General-
• Enable gravity: -9.81 m/s² in y direction 

to include the effect of gravitational 
force on the droplets

• Models
– Turbulent Flow    (Re~400,000*)

• Enable the Realizable k-epsilon Model
ith E h d W ll T t t• with Enhanced Wall Treatment

• Materials
P G d t b Ai– Process Gas assumed to be Air 
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*Assuming process gas as air @STP, Re=1.225*15*0.4/1.7894E-5 = 410,752
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Customer Training MaterialSetup Single Phase (2)

• Boundary Conditions
– Define the “Inlet“ boundary:

• Type: Velocity Inlet
• Velocity: 15 m/s
• Turbulent Intensity: 3 %
• Hydraulic Diameter: 0.4
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Single Phase (3)

• Boundary Conditions
– Define the “Outlet“ Boundary:

• Type: Pressure Outlet
• Gauge Pressure: 0 Pa
• Backflow Turbulent Intensity: 3 %

B kfl T b l t Vi it R ti 10• Backflow Turbulent Viscosity Ratio: 10  
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Discrete Phase Model (1)

The Discrete Phase Model tracks the motion of individual (discrete)
particles.  Note that the same principles apply whether the object is a solid 
particle, or as in this case, a liquid droplet.  p , , q p

The trajectory of each particle (droplet) is computed over a large number 
of steps as it passes through the flow domain.  Since we know the mass 
and the surface area of each particle at each step the solver can computeand the surface area of each particle, at each step the solver can compute 
the balance of forces acting on it.  Integrated over the flow domain, the 
overall trajectory can be determined.

Unlike the continuous phase (air) where material flows through the grid 
cells (known as an ‘Eulerian‘ reference frame), the DPM moves particles 
were each particle has its own x,y,z co-ordinate (known as a ‘Lagrangian‘ 
reference frame)reference frame).  

In this case the particles (droplets) are inert, however the DPM does 
support much more complex cases where the particles may evaporate 
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and/or combust.



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Discrete Phase Model (2)
• Models > Discrete Phase > Edit
– Increase Max. Number of Steps to 50000
– Keep Step Length Factor at 5.p p g

The options seen here are:
• “Interaction with Continuous Phase“ – if this was selected (but do

not select it now) this would mean that that as well as the )
continuous (air) region influencing the particles, the particles will also 
influence the momentum / energy of the air.

• “Step Length Factor“ indicates how many steps each particle should make across a grid cell

• “Max Number of Steps“ sets a limit for the number of steps.  Sometimes particles are trapped in a 
recircilation region, and this parameter is needed to stop the solver being trapped in a continuous loop.  
Note that if this value is too small, some particles will be terminated too early, before reaching the 

it/ ll ( hi h ill b t d hi h b th t ‘i l t ‘)
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exit/walls (which will be reported as a high number that are ‘incomplete‘)
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Customer Training MaterialSetup Discrete Phase Model (3)

– Injection Type: Surface
Release from Surfaces: Inlet

• Define – Injections – Create

– Release from Surfaces: Inlet
– Particle Type: Inert
– Diameter Distribution: Rosin- Rammler
– Select ‘Inject Using Face Normal j g

Direction’
– Set Point Properties as per table below, 

then ‘OK’ :

Property
Velocity (normal to inlet) 15 m/s

Mass Flow 0.05 kg/s This injection defines the release conditions for the 
DPM particles/droplets Note that with a ‘surface‘

Min. Diameter 5e-6 m

Max Diameter 1e-4 m

Mean Diameter 5e-5 m

DPM particles/droplets.  Note that with a surface  
injection, one particle stream is released from each 
cell on the ‘inlet‘ face.  So if (for example) there are 
actually 105 particles, yet only 102 cells on the inlet 
face, then there will only be 102 ‘particle streams 

3
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Spread Factor 3.5

Number of Diameters 20

tracked.  Each will carry the mass flow rate of 103

actual particles (though their trajectories will be 
based on the mass / diameter of a single particle)
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Customer Training MaterialSetup Discrete Phase Model (4)

• Materials
– We want to simulate liquid droplets with a 

density of 700 kg/m3y g
– Currently we have the default ‘anthracite’ 

particle material.
– To adjust this, Double Click anthracite in the 

Materials panelMaterials panel
– Setup new Name and Values as shown on the 

image
– Store information by clicking 

Change/Create
– Click Yes to overwrite anthracite.
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Discrete Phase Model (5)

• Turbulent Dispersion 
– Activate the Discrete Random Walk Model
– Enter 10 for Number of Tries – to calculate 10 

possible paths for each droplet.

To account for the random-ness of the 
turbulent motion, each particle can be 
given a ‘kick‘ based on the local 
turbulent intensity.

“10 Tries“ means that 10 releases will10 Tries  means that 10 releases will 
be made from each point to see the 
scatter imparted by the turbulence.

Referring to the example in the 
commentary on an earlier slide, there 
would now be 103 (102 x 10) particle 
streams tracked, with each now carrying 
the mass of 102 particles (105 actual 
droplets divide by 103 particle streams)
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droplets divide by 10 particle streams)



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSetup Discrete Phase Model (6)
The solver needs to know what to do with a DPM 
particle / droplet when it meets a flow boundary.  Note 
the additional ‘DPM‘ tab on the Boundary condition 
panels for this.   The main choices are:
– ‘Escape‘ if particles are free to leave at this boundary
– ‘Reflect‘ if they will bounce off this boundary
– ‘Trap‘ if they will stick to this boundary

• DPM Boundary Conditions:
– Set the DPM conditions for the 

boundaries as per the table below:

Boundary DPM BC Physical Meaning

inlet escape -

tl t P ti l l th d i T ki doutlet escape Particle leaves the domain – Tracking ends

wall trap Particle is removed but its current mass and energy is 
imparted to the gas phase.
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wall_pipe-[*] reflect Particle rebounds off of the pipe wall with the normal and 
tangential coefficients of restitution set in the reflect panel.



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSolver Settings (1)

• Solution Methods
– Switch to Coupled for Pressure-Velocityp y

Coupling
– Green-Gauss Cell Based for Gradient 

Discretization
– Switch to Second Order Upwind for

Momentum
• Solution Controls
– Decrease the

Courant Number to 50 

WS6-15
ANSYS, Inc. Proprietary
© 2010 ANSYS, Inc.  All rights reserved.

Release 13.0
December 2010



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSolver Settings (2)

• Monitors:
– Residuals : Set Convergence Critiera to ‘none‘

• Initialize – Compute from all-zones
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialSolving

• Run the model for 100 Iterations

Recall that we did not select ‘Interact with Continuous Phase‘ when setting up the DPM.  The trajectories 
have not yet been computed, all we have currently solved for is the movement of the continous phase 
(air).  The DPM computation will happen when we post-process the particle trajectories.
However if we had selected ‘Interact with Continuous Phase‘, then at every pre-defined number of 
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, y p
iterations, the DPM particles would have been tracked.  These would have provided a revised momentum 
source/sink for the air, and as a result we would see spikes in the residuals at each DPM computation.
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Customer Training MaterialPost processing (1)

• Display Velocity Contours:
– Display contours of the Velocity Magnitude at the Symmetry plane

Align view angle by using:• Align view angle by using:
> Views > Front > Apply
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialPost processing (2)

• Display Particle Tracks
– Graphics and Animations > Particle Tracks
– Choose Draw Mesh > Symmetry Plane > Edge-Type 

Outline > Display > Close
– Select ‘injection-0‘ to release from
– Colour by Particle Diameter

Skip Tracks by 5– Skip Tracks by 5
– Coarsen each track by10 (only every 10th calculated 

Point on a track will be displayed)
– Select ‘Display‘ and wait
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialResults

• At this point (when pressing ‘Display‘ on the previous slide) the DPM iteration 
is performed.  The status of this is shown in the TUI window:

– The Number of incomplete particles should be zero.   If not, the “Max. 
Number of Steps“ can be increased (Models > Discrete Phase). 

– If increasing the steps does not change the number of incomplete particles 
then particles are quite likely caught in a recirculation zone(s). In this case, 
revert this setting as it is not efficient to run too many steps for particles that 
are caught in a recirculation zones.
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialPost processing (3)

• Obtain the Diameter Distribution at the 
Outlet using the Discrete Phase 
Sample/Histogram panels

• First, create a DPM Sample File
– Reports > Discrete Phase > Sample
– Select ‘outlet‘ ‚‘injection-0‘ and ‘Compute‘
– Whenever a Particle passes a chosen 

Zone, its current properties will be written 
out to a file [zone name].dpm[ ] p

– The Files are located where FLUENT case 
and data files are stored (for WB Usage: 
[WB_project_name]_files/dp0/FLU/Fluent/
outlet dpm)outlet.dpm)
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialPost processing (4)

• Second, display this sample file using the 
Histogram optionHistogram option.

• Reports > Discrete Phase > Histogram
• Click the Read button.

– A File browser will open; select the sample fileA File browser will open; select the sample file 
that was just created (outlet.dpm)
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialPost processing (5)

• Switch off the Weighting and select 
diameter under the Variable column.

• Click Plot to see a bar chart of theClick Plot to see a bar chart of the 
diameter bins at the outlet.
– In TUI Console, you can see some 

statistical details
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialAppendix - Post-processing in CFD-Post

• You can read the case and data files in CFD Post 
but, in order to visualize the Particle Tracks in 
CFD Post, you need the Track file
– File > Export > Particle History Data
– Select ‘injection-0‘
– Set ‘Skip‘ to 5, and ‘Coarsen‘ to 10
– Particle Filename : ‘dpm-results.xml‘
– ‘Write‘

Recall that the DPM trajectories are computed in their own Lagrangian reference frame – in other words the 
t j t i t t f th l “fl id“ d t t d f h id ll A lt th DPM t j t i
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trajectories are not part of the normal “fluid“ data stored for each grid cell.  As a result, the DPM trajectories 
are not saved as part of the FLUENT case & data file.   If these are to be post-processed in CFD post, the 
DPM “Particle History Data“ needs to be exported as a separate file.



WS6:  Discrete Phase Model (DPM)

Customer Training MaterialAppendix – Post-Processing in CFD-Post[2]
• Save your Case & Data (or Project if in Workbench)

• Close FLUENT

• [If in Workbench]  Right-click on the solution cell, and select  “Transfer Data to 
New” then “Results”.   Double-click on ‘Results’ to launch CFD Post

• [If standalone]  Launch CFD-Post, and read in the case and data file.

• [Both Methods, in CFD-Post]  File > Import > Import FLUENT Particle Track File.

• Select the file saved on the last slide “dpm-results.xml”.
If in Workbench, this will be :
[WB_project_name]_files/dp0/FLU/Fluent/dpm-results.xml
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WS6:  Discrete Phase Model (DPM)

Customer Training MaterialAppendix  Post-Processing in CFD-Post[3]
• A new item appears in the model tree “FLUENT PT for Liquid”
• To re-create the image shown, increase the “Maximum Number of Tracks” to 2000, 

and colour by Velocity then ‘Apply’

In this case there were 1120 mesh 
faces across the inlet.  We used 
turbulent tracking with 10 tries.  

Hence if FLUENT simulated all 
trajectories, that would be 11200 
particle tracks computed.

When we exported the dpm data 
from FLUENT, we applied a ‘skip’ 
of 5 (so only every 6th line is 
exported) Hence the data file willexported).  Hence the data file will 
contain 1870 trajectories.

By setting max tracks to 2000 we 
plot everything in the data file If
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plot everything in the data file. If 
you increase this value, no 
additional tracks are displayed.
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Customer Training MaterialAdditional Work [Optional]

In this example, we chose to only offer one-way coupling between the fluid (air) and 
the droplets.  The air flow influenced the particles, but not the opposite.  The 
particle motion had no influence on the air flow.  By doing this the workshop could 
b f i l i klbe run fairly quickly.

However you may be concerned that the loading of the droplets may be significant, 
and their presence may modify the air flow pattern To check this try computingand their presence may modify the air flow pattern.   To check this, try computing 
with coupled motion
In the FLUENT setup:

• Go to Models > Discrete Phase• Go to Models > Discrete Phase
• Set ‘Interact  with Continuous Phase’ 
• Set ‘Number of Continuous Phase 

Iterations’ to 20 then ‘OK’Iterations  to 20, then OK .
• Run the simulation for a further 250

iterations (or for however much time
you have) and repeat the
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you have) and repeat the 
post-processing
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